github twitter email rss
Raspberry Pi编译驱动(8188eu)
Nov 4, 2015
1 minute read
  1. 下载内核源码,,用uname -r查看本机内核 wget https://github.com/raspberrypi/linux/archive/rpi-4.0.y.tar.gz tar xzf rpi-4.0.y.tar.gz
  2. 确保gcc版本是4.6gcc -v, 4.8无法正常编译内核
  3. 将源码移至目录/usr/src,并建立软链至/lib/modules/ [sudo] mv linux-rpi-4.0.y /usr/src [sudo] ln -s /usr/src/linux-rpi-4.0.y /lib/modules/`uname -r`/build cd /lib/modules/`uname -r`/build
  4. clean下源码,生成make的config,预备编译内核 make mrproper modprobe configs zcat /proc/config.gz > .config modules_prepare
  5. 为了节约时间不重头编译内核,下载

updated: 此文件会随着内核版本变动,请下载对应版本,否则就算编译成功也不可用,版本参考https://github.com/raspberrypi/firmware/commit/13aa07f322b6f1645508b5c24ad70035f2a963d5

wget https://github.com/raspberrypi/firmware/raw/master/extra/Module7.symvers
cp Module7.symvers Module.symvers
  1. 编译驱动8188eu cd ~ wget https://github.com/lwfinger/rtl8188eu/archive/master.zip unzip master.zip rm -rf master.zip cd rtl8188eu sudo make -j4 sudo make install

参考链接: link1 link2


Back to posts


comments powered by Disqus